Subscriber Count

    463

Subscribe to Posts by Email

Pages

ORA-28040: No matching authentication protocol Database driver error

Hi

Hope you might have already gone through below, just in case if not.  All of our developer tools/ETL tools datastage/Informatica etc. are failing with ora-28040 once we upgraded to oracle 12c.

This is due to, As per Oracle, In Oracle 12.1 the default value for the SQLNET.ALLOWED_LOGON_VERSION parameter has been updated to 11. This means that database clients using pre-11g JDBC thin drivers cannot authenticate to 12.1 database servers unless the SQLNET.ALLOWED_LOGON_VERSION parameter is set to the old default of 8.

Change/add the SQLNET.ALLOWED_LOGON_VERSION=8 in sqlnet.ora

Note: For the databases on AWS RDS this still works.

-Thanks

Suresh

Leave a Reply

You can use these HTML tags

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>